You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 13dwf (Sep 7th 2010, 1:03pm)

4 492

by Wet_Boots

(Sep 9th 2010, 8:50pm)

by RedArt (Aug 15th 2010, 11:03am)

3 1,599

by mrfixit

(Aug 31st 2010, 2:23pm)

by henry2clue (Jun 1st 2010, 7:30pm)

1 1,505

by mrfixit

(Jun 2nd 2010, 2:27am)

by DRegs (May 5th 2010, 5:29pm)

1 329

by Wet_Boots

(May 6th 2010, 2:34pm)

by stillc (Jul 29th 2009, 12:36pm)

2 737

by Wet_Boots

(Aug 4th 2009, 1:08am)

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 297

by Wet_Boots

(Jun 26th 2009, 8:58am)

by Roger Stover (Jun 16th 2009, 11:09am)

4 193

by hi.todd

(Jun 19th 2009, 10:27pm)

by Brie (Feb 24th 2009, 11:42am)

2 631

by sanzen96

(Mar 21st 2009, 3:55pm)

by skimi (May 6th 2008, 12:27am)

5 2,394

by jbsbeach

(Jan 7th 2009, 7:18am)

by lawnlover (Jun 21st 2008, 3:40pm)

1 2,139

by Wet_Boots

(Jun 21st 2008, 5:48pm)

Show

Statistics:

455 Threads - 1,700 Posts (average 0.36 Posts per Day)