You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 95mmrenegade (Jul 20th 2014, 10:30am)

4 33

by Central Irrigation

(Jul 20th 2014, 2:43pm)

by mjtalmadge (Sep 11th 2011, 2:30pm)

4 2,034

by Jlinfield

(Jul 4th 2014, 11:42am)

by Texas Tarheel (Jun 19th 2014, 8:33pm)

8 73

by irrigirl

(Jun 24th 2014, 12:26pm)

by ash13 (Jun 1st 2014, 10:06am)

4 119

by Central Irrigation

(Jun 1st 2014, 6:17pm)

by LT87 (May 21st 2014, 11:33am)

3 101

by hi.todd

(May 27th 2014, 1:03pm)

by noquarter (May 24th 2014, 1:22pm)

6 72

by Wet_Boots

(May 26th 2014, 6:22am)

by abcoker (May 9th 2014, 2:43pm)

5 129

by Wet_Boots

(May 23rd 2014, 7:04am)

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 145

No reply

by andyl (Apr 21st 2014, 8:32pm)

3 113

by Wet_Boots

(Apr 27th 2014, 9:26am)

by JAshburn (Apr 23rd 2014, 10:04pm)

3 90

by Wet_Boots

(Apr 24th 2014, 4:22pm)

Show

Statistics:

430 Threads - 1,627 Posts (average 0.36 Posts per Day)