You are not logged in.

Search results

Search results 1-8 of 8.

Tuesday, May 30th 2017, 11:35am

Author: LarsB

Can this pump be fixed (vid)

Can this pump still be fixed or is it beyond hopeless? It still works, but is extremely loud (what's causing the loud noise?). Take a look at the quick video. It was already noisy, but it got worse over the weekend. I don't see a way to embed the video, so just the link. I just uploaded, so hopefully it will show up already. vid

Friday, February 17th 2017, 3:46pm

Author: LarsB

Just fixed the pump and it still doesn't pull the water from the well

Thank again for your time and answers, I'll try to eliminate all and any air leaks now.

Thursday, February 16th 2017, 1:44pm

Author: LarsB

Just fixed the pump and it still doesn't pull the water from the well

I am a little bit confused as to what I am supposed to do now? Pump is pumping city water, sprinklers are spraying the water onto the lawn, so it seem as it is working. That little drain hole cannot be possibly affecting the pumping of the water from the well, can it?

Wednesday, February 15th 2017, 11:48am

Author: LarsB

Just fixed the pump and it still doesn't pull the water from the well

I'll try to plug it with something, thank you. How about my second question? How do I go about the pump not pumping well water, but it does work with city water. How do I determine what is causing it not to pull the well water, how would a professional go about it? Can anyone help here?

Tuesday, February 14th 2017, 10:15am

Author: LarsB

Just fixed the pump and it still doesn't pull the water from the well

Thanks again for the reply, is that what it is? Drain plug? It's just a tiny 1/16" hole. Should I just plug it with a screw or something? More importantly how do I test whether the water level is too low? It's been raining over the summer and fall very nicely here, I'd think all the water supply would refill itself, but it's not been pulling water for quite awhile now. What else can I check for? Any kind of valves?

Monday, February 13th 2017, 2:44pm

Author: LarsB

Just fixed the pump and it still doesn't pull the water from the well

Thank you for the reply. I don't know these boards too well or how they work. I thought I have inserted the photos (used the little icon and inserted the URL there) and they showed in my post the way I thought they would, I guess not so on other computers. Anyways, the water is leaking from a little appendage or a protrusion for lack of better word. It is cast iron and it been made as part of the cover, it doesn't leak from the shaft. I just don't understand a need for something like that. It's ...

Monday, February 13th 2017, 1:52pm

Author: LarsB

Just fixed the pump and it still doesn't pull the water from the well

Goulds Pumps, ITT GT20 was severely leaking and it was not using well water, could only work with city water. Someone quoted me $900 to replace the whole pump, but I was thinking why, if the motor works? I found the parts for $100 and replaced it and it wasn't too bad, unfortunately the pump is still not pulling the well water. On top of that it leaks from a weird place, that I don't know how to describe, I'm including a photo, i couldn't get any better as there is no easy access to that spot. I...