You are not logged in.

Search results

Search results 1-4 of 4.

Tuesday, November 17th 2015, 6:34pm

Author: boniam

Sprinkler winterize through back flow preventer test port not working. HELP

Thanks Guys. I tried again and it worked. I had to increase PSI to about 60 initially and BFV sealed. In some cases i had to remove air hose and put it in after pressure built in. Anyway done with my 9 zone for this year. I might do it one more time over the weekend but it was nice to get as much as i could tonight as it is going to be 25 deg here, Thanks again for help.

Tuesday, November 17th 2015, 9:25am

Author: boniam

Sprinkler winterize through back flow preventer test port not working. HELP

Thanks Wet_Boots! Ok Here is the image. Is the consensus is to use drain port and not Test Port 1 or 2? Should I close both BFP valve v1 and v2, connect hose to drain port, Open V1 when BFP seals open V2? Is there anyway to use test ports as I have those attachments so would like to get this done quickly for this year. Is there anyway to seal back flow and use test port?

Tuesday, November 17th 2015, 7:27am

Author: boniam

Sprinkler winterize through back flow preventer test port not working. HELP

#mce_temp_url# Sorry I am little confused about terminology. My setup is like above . Do you think I should blow through drain port and close V2. Let the pressure build and poppet to seal and then open V2. I don't have fitting for drain port and already hooked up for test ports. Is there a way to use test ports and seal PVB. EDIT: Sorry my pictures is not coming. I am trying to figure out how to upload pictures.

Monday, November 16th 2015, 11:16pm

Author: boniam

Sprinkler winterize through back flow preventer test port not working. HELP

This probably has been covered many times but i still see so many opinion. I have a Febco 765 BFP with two test port. I also have a drain valve between Febco and my water supply but nothing after Febco. I tried to blow through lower test port # 2 and it worked at first for 1 zone but but then started making loud sound on second zone (as if pressure is building and no where to release. Then i tried test port 1 and the air was coming from the top of BFP. I took top of BFP out, took out bonnet and ...