You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 2 posts

Wednesday, June 25th 2014, 6:30pm

by Central Irrigation

You're using granular fertilizer? The system is designed to use water to dissolve the fertilizer and then inject the infused water back into the sprinkler system.

Wednesday, June 25th 2014, 2:08pm

by Oldguy S. (Guest)

EZ Flo isn't pumping out fertilizer

I've been disappointed in the results of our professionally installed system. Plants just don't seem robust. After a year with the contractor, we decided to do it ourselves. when it came time to refill the tank, we found to our surprise that it looked full of fertilizer ... nonetheless, we added more according to the directions after emptying half the tank ... the system pumps out water not fertilizer ... everything seems to be functioning but it's not sucking up the fertilizer ... probably what's been going on all along. We have an EZ Flo 1.5 gallon unit ... any thoughts are greatly appreciated.