You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 695 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 2 posts

Monday, November 5th 2012, 5:12pm

by Wet_Boots

Did the kit include a new spring? Did you use the flow control to throttle down the valve? (very important for increasing service life)

Monday, November 5th 2012, 12:52pm

by DannnO

Irritrol 700 won't shut off

I replaced all parts with repair kit. Line pressure 60 PSI. The valve turns on and water flows. The valve turns off and the water still flows. I have cleaned everything b4 replacing parts. I made sure the to blow out the the small orifices. Replaced solenoid. Now, when I turn off the water to the valve (electricity off), and wait awhile, then turn the water back on, the water doesn't flow. How do I fix this problem?