You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 896 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 8 posts

Wednesday, May 9th 2012, 5:02pm

by Skiddy (Guest)

Pressure switch

Now that sounds like a fix for the worries. I will look into this, thanks for the info .

Wednesday, May 9th 2012, 11:49am

by Wet_Boots

There can be had temperature sensors that will read an overheating condition, and shut off a pump. For pumps that are controlled by a pressure switch, a version with an additional low-pressure cutoff exists. A loss of prime would trip the cutoff.

Wednesday, May 9th 2012, 8:21am

by GatorGuy

Skiddy,
first I'll state up front my experience with pumps is limited.

We just started carrying a new line of pumps. During our discussions with the factory rep he mentioned varying water tables.

He said that in some parts of the country water tables fluctuate greatly, often over 5' in a 24 hour period.
Partially because of community growth, partially because the recent drought did not let tables replenish as normal.

All this to say that Wet_boots is probably right.

Wednesday, May 9th 2012, 8:13am

by Skiddy (Guest)

Pump lost prime and overheated

That makes sense. I have it all running just fine again, but am afraid to leave it plugged in over night for fear it will run dry again and overheat the pump. That can't be good for the internal parts of the pump, and I am surprised it still runs after the first overheating. The water was boiling inside the pipes.

Wednesday, May 9th 2012, 7:00am

by Wet_Boots

Pros who work in the region claim that the different expansion rates for PVC and metal can cause suction leaks at the pump connection. Also, a lowering water table can interfere with pump performance.

Tuesday, May 8th 2012, 11:28pm

by Skiddy (Guest)

lost prime

Yeah I was given that advice from a friend and took care of it today. That Galvanized is a bear to get tight and sealed up. I installed unions at each line as to service the unit without all the cuts and trips to the hardware store.

I still have no idea why it ran all night and lost prime?

No takers on that one?

Tuesday, May 8th 2012, 3:31pm

by Wet_Boots

Do yourself a favor and only use galvanized steel connecting to the pump. Transition to PVC a foot or so away.

Tuesday, May 8th 2012, 10:41am

by torr@tampabay.rr.com (Guest)

Sprinkler pump overheated

I woke up the other morning to hear my pump running on a non watering day? When I came out to check it I noticed it sounded quiet, and realized there was no water running through the pump, it was dry, almost as if I lost prime. I then unplugged the pump.I am in the process of replacing all the PVC because it swelled up from the heat and now leaks from the joints. I could really use some help figuring out why this happened in the first place. I have a cast Iron pump that seems to be working fine so it wasn't burnt up. I have a shallow well with a check valve just above the surface in line.
Thanks for any help,