You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 3362 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The first post

Monday, September 12th 2005, 5:39pm

by macann

Febco 765 spewing water

I have a problem with a new Febco 765. It is new and professionally installed. I open the inlet value to the Febco and it appears to open properly. Then I open the faucet which is attached about 2" to the left of the Febco outlet. Water starts spewing out the top of the Febco.

I put the sprinkler system in myself but haven't tried to test it yet until I resolve this problem.

I read that the sprinkler valves must be at least 12" below the Febco (which they are) but I am thinking that at least one problem I have is the faucet too close to the Febco? Any comments would be appreciated.

Thank you,
Maureen